Jump to content
Lysithea_ciel

Touhou 7 constantly scrolling up [Fixed]

Recommended Posts

I just got PCB. Whenever I start the game, it's as if the up arrow key is constantly being held down. Pressing down pauses it for a second, then it goes back to scrolling up. This only happens with th07 (thpatch-en).exe; the japanese version behaves as normal. I've tried reinstalling the game, restarting my computer, and getting the enbconvertor thing, with no luck. Any ideas on how to fix it?

Share this post


Link to post
Share on other sites

try to re-patch the game your self in thcrap

Share this post


Link to post
Share on other sites

How do I do that?

Share this post


Link to post
Share on other sites
Posted (edited)

Are you using desktop computer or laptop?
If is desktop computer, this may sound dumb but try unplug the keyboard, and start the game by double-clicking with the mouse. If the game runs normally, it may be your keyboard is broken.

If the problem persist.
(both desktop computer and laptop) try making a backup of "score.dat" and "th07.cfg", and then delete these files from the main folder.
try again.
if doesn't work, try closing other programs that might be running in background.

still nothing?
1) Make a clean copy of TH07, (copy "th07.dat", "th07.exe", "custom.exe" and "Thbgm.dat" into a new folder.)
2) download thcrap
https://www.thpatch.net/wiki/Touhou_Patch_Center:Download
3) Unzip the files in a short path (for example, C:\Touhou\)
also copy the clean copy of TH07 there.

For example:
for thcrap "C:\Touhou\thcrap_brliron\
and for TH07 "C:\Touhou\Touhou\Touhou 07 - Perfect Cherry Blossom"

4) go to the directory \thcrap_brliron and run thcrap_configure.exe
The program will guide you through the language configuration.

 

Press Enter

wMZwHeE.jpg

Scroll up and search for your desired language, in this case will be English. Enter the number in the box and press enter.

SJXJQxJ.jpg

If you want to add another language or modification just type the number in the box.
If you are fine just press enter.

k2p5cNm.jpg

Press enter.

smlC5ZM.jpg

Again, press enter.

b3pDDhz.jpg

The program will ask you for your game directory.

E6PcOlM.jpg

Type "1"

RoW9cOs.jpg

Select "yes"

XnnJUHM.jpg

Wait for the program to complete the download.

amH1b3X.jpg

And that is it.

pUlO8Fn.jpg

Edited by -Prismriver-

Share this post


Link to post
Share on other sites

I tried your first set of suggestions, then again after making a clean copy of TH07 with thcrap added; still broken.

I'm wondering if this is just a problem with Moriya's latest version of TH07, as it was most recently updated about 2 weeks ago. Is there a place I can download older versions?

Share this post


Link to post
Share on other sites

It works! Many thanks, friends

  • Like 1
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.